Fix the error ITMS 90208: Invalid Bundle. When uploading your app on Apple Store Connect
1 min read

Fix the error ITMS 90208: Invalid Bundle. When uploading your app on Apple Store Connect

ERROR ITMS-90208: 'Invalid Bundle. The bundle Runner.app/Frameworks/App.framework does not support the minimum OS Version specified in the Info.plist.'

Today I had to update a Flutter app that I successfully uploaded on the App Store Connect some months ago.

In the meanwhile Flutter and the project dependencies were updated, and the app was working both in debug mode and when distributed in-house.

While uploading I received this error:

ERROR ITMS-90208: "Invalid Bundle. The bundle Runner.app/Frameworks/App.framework does not support the minimum OS Version specified in the Info.plist."

The quick workaround I tried was to change the MinimumOSVersion in ios/Flutter/AppFrameworkInfo.plist from 8.0 to 9.0:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <dict>
        <key>CFBundleDevelopmentRegion</key>
        <string>$(DEVELOPMENT_LANGUAGE)</string>
        <key>CFBundleExecutable</key>
        <string>App</string>
        <key>CFBundleIdentifier</key>
        <string>io.flutter.flutter.app</string>
        <key>CFBundleInfoDictionaryVersion</key>
        <string>6.0</string>
        <key>CFBundleName</key>
        <string>App</string>
        <key>CFBundlePackageType</key>
        <string>FMWK</string>
        <key>CFBundleShortVersionString</key>
        <string>1.0</string>
        <key>CFBundleSignature</key>
        <string>????</string>
        <key>CFBundleVersion</key>
        <string>1.0</string>
        <key>MinimumOSVersion</key>
        <string>9.0</string>
    </dict>
</plist>

Wanna stay up-to-date with Flutter and Dart?

Subscribe to get a weekly email with the best articles about Flutter and Dart.

    We won't send you spam. Unsubscribe at any time.